Posts Tagged ‘ Indicator ’

Rocky


Yesterday turned into a nightmare. I can hear the groans already! Whilst I was content with my early +20 I did have one other trade and what should have been an elementary win turned into a farcical loss and a big loss. An errant lack of concentration when placing my stop cost me dearly. Without going into further drama I completely messed up the TP and SL levels and ended up taking myself out for -40 instead of a +20 win. I also failed to cancel a pending trade from much earlier in the day as I rarely have the terminal showing within MT4 as I like to keep as much space free for the graphs. It just touched the entry and spiralled to a loss for another -30. This all happened whilst I left to go and do some grocery shopping for literally 30-45 minutes and the shock when I came back was unreal. Needless to say I was pissed and went about trying to rectify it and make back the losses immediately. A further loss ensued and I was staring into the abyss before some sense got into me and I took a step back and evaluated things.

Mistakes can and will happen but it isn’t the first time I’ve got my SL wrong and more care and attention is clearly needed and I’ll be looking to do just that when I’ve completed the move to Australia. A couple of strong trades today have eliminated yesterday’s disaster and even a small profit. TUFXP hit the mark again today but took a little longer than usual to signal a trade. Very, very early days yet but I think this could be a decent replacement for my old TUFXP method. What is worth mentioning however is the fact that it is 99% identical to ATM-FX which costs 1/10th of the price. Unless you can find other uses for TUFXP which at the moment I do then I really can’t see the advantage of paying an extra £1,900 for the software. Sure it’s helpful having a nice little circle but with practice ATM-FX could equally become second nature and a few programmers could probably even organise an indicator to highlight a trade.

A quick note: It appears I’m using a different MA to CM. I emailed him last week asking which MA he’s using and he said standard which he thought was 20. I’ve tried various settings and I was briefly on 8 but now switched to 20 and looking at today, they appear to match. If anyone knows for sure if it’s 20 then it would be good to hear from you.